Forums > Diskimage 1.6 under Windows 7 64 bitSearch  Log In
Joined: 4 Dec 2010
Maidstone, Kent, UK
Posted: 5 Dec 2010
Diskimage 1.6 running on Win 7 64 bit gives an error "Error #5 occurred while writing to disk at sector 0" when writing to a USB stick in physical disk mode. Other users have reported the same issue.

It works OK on an XP machine.
Joined: 20 Oct 2010
Posted: 10 Dec 2010
(I repeat my old message)

DiskImage doesn't work correctly under Windows 7. Actually it can't write to UFD!

A possible solution to get it work was described here:

Please, Mr.Roadkil, if you are still interested in developing DiskImage, have a look on this info.
Joined: 28 Mar 2008
South Australia
Posted: 3 Mar 2011
Hi there.. I havent been able to replicate this problem - Im wondering if its UAC related. Ill try adn replicate on another machine and put ina fix!

Joined: 16 Jul 2013
Posted: 16 Jul 2013
Hi Jason? err Mr Roadkill..
I definitely have the same or a similar problem with Windows 7 64 bit. In my case - I think the first time I did the Physical write to a USB SDHC adapter - I got "Error #5 occurred while writing to disk at sector 8182". Now every time I try to write the same image to the same physical USB drive - I get "Error #5 occurred while writing to disk at sector 2048"
I don't know whether this is relevant - but the partition table in teh disk image should have 2 partitions - the fiurst being small around 40 megabytes - and the second being most of a 4 gig drive. After the initial error 0 roadkill seems to see the fist partition - but doesn't mantion the second partition. I thought that was a bit strange... If it had written the partition table - I thought it would see both partitions...

I tried setting Roadkill Diskimage to Windows XP SP3 compatibility mode - but it didn't seem to help.

Thanks for a really useful product...

Joined: 16 Jul 2013
Posted: 16 Jul 2013
Some more information...
I tried the doing the same write to the same physical disk using 32 bit Windows 7 machine and it also failed in much the same way - with the slightly different message:
"Error #5 occurred while writing to disk at sector 0".
In my case the image I am trying to write was successfully "Stored" by Disk Image from a 4 Gig Linux USB drive with 2 partitions - (Using a windows machine of course). I am trying to write it to a 32 gig micro SD card in a USB reader.

Page: 1

You must log in to reply to messages
Please log on
User Name:
Forgotten your password? Click here